Помощь - Поиск - Пользователи - Календарь
Полная версия этой страницы: Проблема Импорт данных
osCommerce по-русски. Форум. > Дизайн и программирование > Базы данных, Easy Populate
shoni
Здраствуйте и снова проблема импорта. Екпортируеться файл - EP2009Aug10-1010.csv
Делаю на основе такойже самый с небольшими корректировками, пытаюсь загрузить товары на сайт - выдает следущее:

Warning: move_uploaded_file(Z:/home/localhost/www/electro/temp/EP2009Aug10-1010.csv) [function.move-uploaded-file]: failed to open stream: Permission denied in Z:\home\localhost\www\electro\admin\easypopulate_functions.php on line 44

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move 'Z:\tmp\php410A.tmp' to 'Z:/home/localhost/www/electro/temp/EP2009Aug10-1010.csv' in Z:\home\localhost\www\electro\admin\easypopulate_functions.php on line 44

File uploaded.
Temporary filename: Z:\tmp\php410A.tmp
User filename: EP2009Aug10-1010.csv
Size: 5345

No products_model field in record. This line was not imported: | 10001,"Act | 2,5 | 4 | 6,3 | 10 | 16


No products_model field in record. This line was not imported: | 10004,"Act | 50 | 63 Устан | | |


No products_model field in record. This line was not imported: | 10003,"Act | 2,5 | 4 | 6,3 | 10 | 16


No products_model field in record. This line was not imported: | 10002,"Act | 50 | 63 Устан | | |


No products_model field in record. This line was not imported: | 10005,"Act | 2,5 | 4 | 6,3 | 10 | 16


No products_model field in record. This line was not imported: | 10006,"Act | 50 | 63 Устан | | |


No products_model field in record. This line was not imported: | 10007,"Act | 2,5 | 4 | 6,3 | 10 | 16


No products_model field in record. This line was not imported: | 10008,"Act | 50 | 63 Устан | | |


No products_model field in record. This line was not imported: | 10009,"Act | 2,5 | 4 | 6,3 | 10 | 16


No products_model field in record. This line was not imported: | 10010,"Act | 50 | 63 Упако | | |


No products_model field in record. This line was not imported: | 10011,"Act | 2,5 | 4 | 6,3 | 10 | 16


No products_model field in record. This line was not imported: | 10012,"Act | 50 | 63 Устан | | |


No products_model field in record. This line was not imported: | 10013,"Act | 2,5 | 4 | 6,3 | 10 | 16


No products_model field in record. This line was not imported: | 10014,"Act | 50 | 63 Устан | | |


Z:\home\localhost\www\electro\admin\easypopulate_functions.php on line 44 - строка:

move_uploaded_file($filename['tmp_name'], $target);

Подскажите что тут неправильно)
modus
Цитата(shoni @ 10.8.2009, 11:05) *
... failed to open stream: ...
Подскажите что тут неправильно)


Не хватает прав записи в файлы со стороны сервера. Нужны права 777
a_berezin
777 - это для *nix-систем, а тут явно windows.
Проверьте, есть поддиректория Z:/home/localhost/www/electro/temp/ ?
shoni
Цитата(a_berezin @ 10.8.2009, 11:39) *
777 - это для *nix-систем, а тут явно windows.
Проверьте, есть поддиректория Z:/home/localhost/www/electro/temp/ ?


С правами уже все в норме, ошибок нету, теперь при загрузке файла данных он мне их просто не добавляет, хотя показует изменения..... Может что-то в запросе не так? Подскажите?
VaM
Ещё ведь написано - No products_model field in record.
т.е. не указан код товара (артикул).

Наверное неправильный просто формат файла, да и с папкой Z:/home/localhost/www/electro/temp/ что-то не то.
shoni
Цитата(VaM @ 10.8.2009, 15:19) *
Ещё ведь написано - No products_model field in record.
т.е. не указан код товара (артикул).

Наверное неправильный просто формат файла, да и с папкой Z:/home/localhost/www/electro/temp/ что-то не то.

Может и формат не потдержует - но выгрузку то он дает именно в этом формате. редактирование происходит тоже в этом формате. А добавлять не добавляет)))))Если что надо закинуть, то скажите. закину))))
VaM
Возможно, что сохраняете неправильно файл в экселе.
shoni
Инетерстно а как правильно его сохранять. Он мне сам говорит - разделитель с запятыми))))

Копирование файла в папку \temp происходит нормально, и уже без всяких ошибок. При открытии самого файла который експортируеться в \temp и правки .css файла вроде все нормально. Когда я заливаю файл обратно на сервер - то он мне показует обновленные товары, и все изменения, но когда вхожу в категорию все остаеться на своих местах, и он не изменен. Пользуюсь - EP_v2_76i_MS2
Помагите разобрать - что я делаю не так, или может ошибка в скрипе))))
shoni
Цитата(shoni @ 10.8.2009, 21:25) *
Инетерстно а как правильно его сохранять. Он мне сам говорит - разделитель с запятыми))))

Копирование файла в папку \temp происходит нормально, и уже без всяких ошибок. При открытии самого файла который експортируеться в \temp и правки .css файла вроде все нормально. Когда я заливаю файл обратно на сервер - то он мне показует обновленные товары, и все изменения, но когда вхожу в категорию все остаеться на своих местах, и он не изменен. Пользуюсь - EP_v2_76i_MS2
Помагите разобрать - что я делаю не так, или может ошибка в скрипе))))


Народ так что мне мона с этим зделать...или может подскажете какой модуль использовать))))
JSinx
Если у вас есть прямой доступ к базе и используете Osc Vam, то можете попробовать мою программку, немного описания в теме http://oscomm.biz/index.php?showtopic=12830.
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.