Помощь - Поиск - Пользователи - Календарь
Полная версия этой страницы: Вывод кол-ва запросо к базе на странице
osCommerce по-русски. Форум. > Дизайн и программирование > Базы данных, Easy Populate
Dzen
Что-то весь поиск перерыл нигде не найду, можно ли сделать вывод кол-ва запросов к базе внизу странице?
по типу:
15 запросов к базе данных за 0.012 сек.

Сборка ВАМа.
Mishka
посмотри в контрибутах Queries Debug Output
VaM
Dzen

У тебя какая версия!?
Это уже было сделано.

Просто включи в Админке - Настройки - Логи - Показывать время парсинга страниц.
Dzen
Цитата(VaM @ 31.1.2006, 12:56) *
Dzen

У тебя какая версия!?
Это уже было сделано.

Просто включи в Админке - Настройки - Логи - Показывать время парсинга страниц.


версия в которой стоит Easy Populate 2.61, в общем сборка не новая но то что ты говоришь я смотрел, оно там есть,
только этот лог показывает Parse Time: 0.490s и всё. А кол-ва запросов к базе не показываетsad.gif
Видать надо контрибут ставить?
VaM
Показывает и время исполнения и количество запросов.
Посмотри в демо-версии сборки.
Dzen
Цитата(VaM @ 1.2.2006, 14:27) *
Показывает и время исполнения и количество запросов.
Посмотри в демо-версии сборки.


у тебя да действительно показывает, а у меня нет, хотя я ничего не делал, в настройках всё включил.

скачал 6.15 loaded включил там логи, и тоже самое :

Copyright © 2003 Oscommerce and CRE Loaded Team
Powered by Oscommerce Supercharged by CRE Loaded Team
Using Version [CRE Loaded v6.15]
Parse Time: 0.821s

про запросы ни слова :-\

Может какая-нибудь несовместимость с мускулем, или это вообще не имеет значения? где хоть смотретьsad.gif

Кстати, твоя сборка появилась вроде бы раньше 6.15 , а потом появилась 6.15 и я подумал а в чём собственно разница то? вроде ведь у них такого не было раньше, а ты первый сборочку сделал или я ошибаюсь.
VaM
Так обновись, может у тебя старая версия, показ количества запросов и время генерации было добавлено не так давно.
Dzen
Цитата(VaM @ 2.2.2006, 12:34) *
Так обновись, может у тебя старая версия, показ количества запросов и время генерации было добавлено не так давно.


а у тебя какая система обновления, я просто не очень пойму, про "обновить" вроде бы ничего нет, есть просто патчи, но вряд ли чтобы обновить надо все их 97 ставитьsmile.gif, а отдельно "обновить до версии такой-то" ничего нет.
или это надо покупать?

кстати увидел в патче что убрали FCK editor, а зачем?
VaM
Зайди в раздел патчи и почитай заметку сверху.

Насчёт FCK, удалён потому что он тяжёлый и не работает в Oper'e.
Также удалены остатки HTML-Area.

На его место установлен редактор TinyMCE, работает во всех браузерах и весит меньше.
Dzen
Цитата(VaM @ 2.2.2006, 18:48) *
Насчёт FCK, удалён потому что он тяжёлый и не работает в Oper'e.
Также удалены остатки HTML-Area.

На его место установлен редактор TinyMCE, работает во всех браузерах и весит меньше.


кстати небольшой офф по поводу tinymce , в опере 8.0 он не работает, не стартурет.
в опере 9.0 стартует, но почему-то не показывает данные из базы:-\ в ОСК не проверял, но в других различных скриптах именно такsad.gif Может там как-то хитро надо яваскрипт настраивать.
VaM
На сайте tinymce видимо погорячились и я тоже, соответсвенно.
У них там есть таблица совместимости, в ней написано, что в Opera поддерживается частично, видимо, это равнозначно тому, что не работает.

Будем ждать тогда новых версий редактора, если там заработает, то я обновлю редактор и в сборке.

Вот ссылка на таблицу совместимости - http://tinymce.moxiecode.com/tinymce/docs/...lity_chart.html
Dzen
Цитата(VaM @ 13.2.2006, 15:05) *
На сайте tinymce видимо погорячились и я тоже, соответсвенно.
У них там есть таблица совместимости, в ней написано, что в Opera поддерживается частично, видимо, это равнозначно тому, что не работает.


Вот 9-ая версия оперы:
_ttp://www.softodrom.ru/files/opera_ru.rar
_ttp://snapshot.opera.com/windows/o90p2_8212.exe

+ еще как интегрировать яву в оперу:
_ttp://www.opera.com/support/search/supsearch.dml?index=470

Не знаю поможет ли это, некоторые говорят что им помогает на версии 8.5
У меня же Тини просто стартует нормально со своими значками.

Недавно читал что вышла новая версия Тини, именно с заточкой под Оперу, дабы была полная совместимость,
только не ясно какой номер версии и действительно ли совместимость полная:-\
VaM
На сайте редактора есть же демка, попробуй в опере её посмотреть.
У меня просто оперы нет.
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.